AIX Frequent Commands

My personal batch of commands that typically consume a large portion of my admin time

bootinfo –r    shows available RAM in KB
lsattr –E l sys0 –a realmem   shows available RAM in KB
rmss -c 512   To change the memory size to 512 MB
rmss -r         resets the memory size to the original value
lsattr  -El  en0    shows en0 driver params
lsattr  -El  ent0    shows ent0 HW params
lsattr -El rmt0    shows tape params
lscfg -vpl rmt0    shows information about the tape drive
lsattr  -El  sys0    shows system type, firmware, etc  driver params
lscfg –v    lists all system HW configuration lsdev –C sscsi    list all scsi devices
lsdev –C spci    list all pci devices
lsparent –Ck scsi    list all scsi adapters
cfgmgr    To onfigure devices
lsdev –Cc disk     Shows all disks
lsdev –Cc tape              Shows all tapes
cfgmgr -vl <device> –v   Specifies verbose output. The cfgmgr command shows information about what it is doing.
cfgmgr -vl <device>      Here <device> is a particular device.
lsdisp    To check which graphic adapter is installed.
lscfg -vpl mga0     shows all information about an adapter.
lscfg -vpl hdisk0 | grep Machine    Shows  info about the disk manufacture type
lsslot -c pci    For 6F1 only Lists all slots ,voltage,boards,etc
bootlist -m normal cd0  rmt0 hdisk0   Changes the default bootlist
lsmcode -c    display the system firmware level and service processor
lsmcode -r -d scraid0    display the adapter microcode levels for a RAID adapter scraid0
lsmcode -A    display the microcode level for all supported devices

Quick for loop to show the interfaces and its necessary details     

for x in ` lsdev –Cs pci|grep ent | awk '{ print $1 }'|cut –c 1,2,4 `;do
    mktcpip –S $x
done      

Networking or network related commands

host timna1    displays station default IP address – works ONLY in DNS environment
ifconfig en0    displays en0 driver params
netstat  -i    displays network interfaces setting
showmount –e <server name>    displays all exported volumes
showmount -a    show filesystemsses mounted over IP !
lssrc –g tcpip    displays all IP oriented processes status
entstat -drt ent0 |grep –i error    display any communication errors on etn0
entstat -r    Resets all the statistics back to their initial values.
arp -a    shows  arp cache
netstat  -ptcp    shows IP statistics
netstat  -pudp    shows UDP statistics
netstat -I en0 5    Trace en0 every 5 seconds
netstat -rn    Display routing info with IP address (10.4.27.182)
netstat -in    Shows the state of all configured interfaces
netstat -r    Display routing info with full hostnames
nfsstat  –z      To  reset NFS stats without reboot
cat /etc/resolv.conf    Check DNS settings
stopsrc –g NFS     To stop NFS services on a client
startsrc –g NFS     To start NFS services on a client
traceroute 149.115.39.1    Trace to the destination  IP
netpmon -o netpmon.out
trcstop
    Traces all network processes activity into a logfile. Must be preceede by a trcstop command !
nslookup hostname    Shows the DNS server name and address
ping -R -c 1 bnc2    Ping with displaying the routing info
namerslv -s | grep domain | awk ‘{ print $2 }’    Displays a fully qualified domain name of a host
rup    Shows the status of a remote host on the local network
nmonnfs    Traces all NFS processes activity
mount hostname:/filesystem /mount-point    Mount an NFS filesystem
mknfsexp -d /directory     Creates an NFS export directory
mknfsmnt                            Creates an NFS mount directory
rmnfs                               Stops and un-configures NFS services
mknfs                               Configures and starts NFS services
exportfs -u <filesystem>          Un-exports a filesystem
exportfs                            Lists all exported filesystems
exportfs -a                        Exports all fs’s in /etc/exports file

Machine details

/usr/bin/uname -m    To get machine ID
/usr/bin/uname -M    To get platform type
oslevel    Shows current AIX level
oslevel -r    Shows current AIX maintenance level oslevel –s  Shows current AIX Service Pack
oslevel -g    List filesets at levels later than maintenance level !!!
lsps -a    Paging space details.
lscfg -vpl proc0  [1,2,3]    Details  about a processor
lscfg -vp l mem0 |pg    Details  about memory modules installed
env ulimit    Environment setings – show user ulimit
bootinfo –s hdisk0     Displays disk size in MB
lsattr -El sys0 -a systemid   Determines the system serial number
lscfg –vp|grep ROM|grep -v CD  Determines the system Firmware level lsfs -v jfs  List of Filesystem items.
lsfs -q -v jfs      See also the parameter of a filesystem and thus see if that is a big_filesystem_enabled one.
Important for the 2GB File limit.
lsuser –f root    Shows all user parameters (max .file size,etc)
sysdumpdev -L    Check last system dump status
sysdumpdev -l    Check system dump device settings
lslpp -f Upd_Timna_DTM.obj    List contents of the package